Comala Workflows is now Comala Document Management. Click here for the latest documentation.

Overview

This page provides information on integrating Brikit Theme Press app with Comala Workflows.

Requirements

  • You will need Brikit Theme Press version v2.1 or later.

Installation

Ideally, Comala Workflows should be installed before Brikit Theme Press app to avoid compatibility issues and get both working correctly together.

A sign that the integration is not working could be the following error trace appearing in your server logs.

...
Caused by: java.lang.NoClassDefFoundError: com/comalatech/workflow/event/StateChangeEvent
...

If Brikit Theme Press app was already installed please follow these steps:

Step 1: Disable Theme Press

Disable the Theme Press app in the plugin manager.

If you fail to disable, the Comala Workflows installation will hang. If the installation hangs, restart Confluence.

Step 2: If Theme Press won't re-enable

If you cannot enable Theme Press after installing Comala Workflows, reinstall Theme Press. You may need to manually re-enable it after reinstallation.

See also